Detection degradation for Cyren Threat InDepth Phishing Feed
Incident Report for Cyren Cloud
Resolved
This incident has been resolved.
Posted Apr 27, 2021 - 17:38 UTC
Investigating
We are currently investigating an issue in our backend that results in degradation in detection for Cyren Threat InDepth Phishing Feed since April 26 13:15 UTC.
Posted Apr 27, 2021 - 13:07 UTC
This incident affected: Intelligence Feeds (Phishing).