Restoration of Services
Scheduled for May 22, 09:00 - 09:05 UTC
Update
Data443 has entered into a definitive agreement to acquire select assets of Cyren Ltd - TIS Services: Anti-Spam, Virus Outbreak Detection, IP Reputation, URL Filtering and data feeds.
Details of the acquisition can be found in the following press release https://www.nasdaq.com/press-release/data443-expands-its-global-customer-technology-base-with-transformative-acquisition.

Data443 provides solutions around data security, governance, archiving, endpoints and cloud services.

Please review the following Q&A page, which we will keep updated: https://data443.com/faq-data443-acquire-cyren/
Posted May 15, 2023 - 14:23 UTC
Update
Standby for official news release.
The Company cautions that trading in its ordinary shares is highly speculative and poses substantial risks. Trading prices may bear little or no relationship to the actual recovery, if any, by holders of the Company's securities.
Posted May 13, 2023 - 14:13 UTC
Scheduled
We are working on restoring service operation. For further details please contact support@cyren.com or your Customer Success representative.
Posted May 11, 2023 - 03:22 UTC
This scheduled maintenance affects: Intelligence Feeds (IP Reputation, Phishing, Malware URL, Malware File) and Threat Intelligence Services (URL Filtering, Anti-Spam, Malware Attack Detection, IP Reputation).