Attachment download not working in Cyren Inbox Security
Incident Report for Cyren Cloud
Resolved
This incident has been resolved.
Posted Oct 07, 2020 - 09:31 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 07, 2020 - 09:18 UTC
Investigating
We are currently investigating an issue in Cyren Inbox Security. Trying to download attachments from Cases results in an error.
Posted Oct 07, 2020 - 08:23 UTC
This incident affected: Cyren Inbox Security (Admin Portal).