Cyren Inbox Security Email Processing Delay
Incident Report for Cyren Cloud
Resolved
This incident has been resolved.
Posted Sep 13, 2021 - 20:51 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 13, 2021 - 18:59 UTC
Investigating
We have identified an issue that causes delays with email processing and button scans by Cyren Inbox Security which began at 16:30 UTC.
Posted Sep 13, 2021 - 17:30 UTC
This incident affected: Cyren Inbox Security (Email Processing).