Cyren Inbox Security Delay in manual remediation
Incident Report for Cyren Cloud
Resolved
This incident has been resolved.
Posted May 30, 2022 - 12:00 UTC
Investigating
We have identified an ongoing issue that is causing delays in performing manual remediation actions of cases.
issue started at 08:22 UTC

This is actively being investigated by our Cyren Inbox Security operations team.
Posted May 30, 2022 - 11:28 UTC
This incident affected: Cyren Inbox Security (Remediation).