ThreatLookup service latency
Incident Report for Cyren Cloud
Resolved
This incident has been resolved.
Posted 3 months ago. May 15, 2019 - 16:00 UTC
Investigating
An issue has been identified where some requests may timeout or respond after 30 seconds.
Posted 3 months ago. May 14, 2019 - 08:00 UTC
This incident affected: Threat Intelligence Services (ThreatLookup API).