Service Alert for Cyren Anti-Spam, Web Security, and URL Filtering
Incident Report for Cyren Cloud
Resolved
The incident has been resolved.
Please contact support to request the root cause analysis document.
Posted about 2 months ago. Jun 26, 2019 - 20:35 UTC
Identified
We are currently experiencing an issue with URLs being misclassified as Phishing.
The issue started at June 25th, 2019, 14:45 UTC.

We are working to resolve the issue.
Posted about 2 months ago. Jun 26, 2019 - 12:49 UTC
This incident affected: Cyren Cloud Security (Web Security, DNS Security), Threat Intelligence Services (URL Filtering, Anti-Spam), and Intelligence Feeds (Phishing).