Cyren Inbox Security Email Processing Delay
Incident Report for Cyren Cloud
Resolved
This incident has been resolved.
Posted Jun 11, 2021 - 14:00 UTC
Monitoring
The issue has been resolved and the system is catching up with email processing. We are monitoring the situation.
Posted Jun 11, 2021 - 01:00 UTC
Identified
We have identified an issue which causes delays with email processing by Cyren Inbox Security as of 20:18 UTC.
Posted Jun 10, 2021 - 23:58 UTC
This incident affected: Cyren Inbox Security (Email Processing).