Cyren Inbox Security Delay in performing remediation, feedback case creation and Add-in scanning results.
Incident Report for Cyren Cloud
Resolved
This incident has been resolved.
Posted Jun 09, 2022 - 13:20 UTC
Investigating
We have identified an ongoing issue that is causing delays in performing remediation, feedback case creation and errors in outlook Add-in scans.
Issue started at 09:30 UTC

This is actively being investigated by our Cyren Inbox Security operations team.
Posted Jun 09, 2022 - 11:39 UTC
This incident affected: Cyren Inbox Security (Outlook Add-In, Remediation, Email Processing).