Cyren Inbox Security Processing Delays
Incident Report for Cyren Cloud
Resolved
This incident has been resolved.
Posted May 09, 2022 - 11:52 UTC
Investigating
We have identified an ongoing issue that is causing delays in the creation of cases and incidents in addition to causing a delay in performing remediation actions.

This is actively being investigated by our Cyren Inbox Security operations team.
Posted May 09, 2022 - 10:30 UTC
This incident affected: Cyren Inbox Security (Remediation, Email Processing).