ThreatLookup Service in EU
Incident Report for Cyren Cloud
Resolved
This incident has been resolved.
Posted Nov 19, 2020 - 16:18 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 19, 2020 - 14:25 UTC
Identified
We identified an issue with the ThreatLookup service in our European data center. You might see some requests failing with an "Error 500".

We are currently working to deploy a fix.
Posted Nov 19, 2020 - 12:40 UTC
This incident affected: Threat Intelligence Services (ThreatLookup API).