Service Alert for Cyren Email Security
Incident Report for Cyren Cloud
Resolved
This incident has been resolved.
Posted Apr 27, 2020 - 15:31 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 27, 2020 - 13:56 UTC
Investigating
Due to a network connectivity issue with one of our Datacenters some incoming connections to the Cyren Email Security Servers may fail.
This can lead to emails being delayed and some emails being received multiple times due to timeouts in the SMTP-communication between the sender and Cyren Email Security.

Incident started today at 09:26 UTC.
Posted Apr 27, 2020 - 09:43 UTC
This incident affected: myEleven (Email Security) and Cyren Cloud Security (Email Security).