Service Alert for Cyren Cloud Security
Incident Report for Cyren Cloud
Resolved
This incident has been resolved.
Posted Nov 12, 2019 - 08:19 UTC
Investigating
Due to a service issue, accessing the Cyren Cloud Security admin portal might result in an error.
Posted Nov 12, 2019 - 08:04 UTC
This incident affected: Cyren Cloud Security (Admin Portal).