Issue with Support ticketing system
Incident Report for Cyren Cloud
Resolved
This incident has been resolved.
Posted Jan 08, 2021 - 10:51 UTC
Investigating
We are currently investigating an issue with emails being sent to our support addresses. You will see the error message:

CyrenSupport@Cyren.com
Remote Server returned '550 5.7.520 Access denied, Your organization does not allow external forwarding. Please contact your administrator for further assistance. AS(7555)'

You can reach our support team via phone and chat in the meantime.
Posted Jan 08, 2021 - 10:42 UTC
This incident affected: Cyren Inbox Security (Admin Portal), Threat Intelligence Services (URL Filtering, Anti-Spam, Malware Attack Detection, IP Reputation, Anti-Malware, ThreatLookup API), myEleven (Admin Portal), and Cyren Cloud Security (Admin Portal).