Service Alert for Cyren Cloud Security
Incident Report for Cyren Cloud
Resolved
This incident has been resolved.
Posted 16 days ago. May 07, 2019 - 19:04 UTC
Identified
An issue with accessing CCS Portal have been identified and a fix is being implemented.
Posted 16 days ago. May 07, 2019 - 18:44 UTC
This incident affected: Cyren Cloud Security (Web Security).