Cyren Email Security Outbound Delivery Issue
Incident Report for Cyren Cloud
Resolved
The rate limiting of our outbound email traffic has stopped. E-Mails that were stuck in the queue because of this issue have been delivered during the night and mail-flow to Gmail is now back to normal.
Posted Jun 18, 2021 - 07:17 UTC
Identified
We have identified the cause for the throttling and have implemented a solution to stop the flow of offending emails to Google.
Posted Jun 17, 2021 - 17:00 UTC
Investigating
We are aware of an issue affecting our outbound delivery to Gmail addresses with an error being returned that some of our Outbound IPs have been temporarily rate limited.

This issue is currently under investigation.
Posted Jun 17, 2021 - 16:27 UTC
This incident affected: Cyren Cloud Security (Email Security).