Service Alert for Cyren Email Security
Incident Report for Cyren Cloud
Resolved
This incident has been resolved.
Posted May 17, 2020 - 21:51 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted May 17, 2020 - 20:24 UTC
Update
While the network connection is still down we were able to mitigate the issue through internal configuration changes. Emails are now processed without delays.

The malfunctioning interconnect can also negatively affect detection performance. We are working together with our Internet Service Provider to get the service fully restored.
Posted May 17, 2020 - 20:22 UTC
Investigating
Due to a network outage in one of our Datacenters the interconnect between the Cyren Email Security datacenters is currently unavailable.

This can lead to delays in email processing and some emails being received multiple times due to timeouts in the SMTP-communication between the sender and Cyren Email Security.
Posted May 17, 2020 - 19:42 UTC
This incident affected: myEleven (Email Security) and Cyren Cloud Security (Email Security).