Service Alert for Cyren Cloud Security
Incident Report for Cyren Cloud
Resolved
This incident has been resolved.
Posted Jul 28, 2020 - 17:57 UTC
Investigating
Due to a service issue, Cyren WebSecurity customers get certificate error.
The issue is under investigation.
Posted Jul 28, 2020 - 16:36 UTC
This incident affected: Cyren Cloud Security (Web Security, DNS Security).