Service Alert for Cyren Web Security and URL Filtering
Incident Report for Cyren Cloud
Resolved
This incident has been resolved.
Posted Feb 07, 2020 - 14:26 UTC
Investigating
We have detected an issue with Cyren URL filtering service classifying amazonaws.com as "Spam Sites".

We are currently investigating this issue.
Posted Feb 07, 2020 - 14:19 UTC
This incident affected: Cyren Cloud Security (Web Security, DNS Security) and Threat Intelligence Services (URL Filtering).