Detection degradation in Anti-Spam service
Incident Report for Cyren Cloud
Resolved
This incident has been resolved.
Posted Nov 16, 2020 - 21:21 UTC
Identified
We are currently investigating an issue causing a degradation in detection performance. We have identified that the degradation began on 15-Nov-20 at 16:00 UTC. The root cause has been identified and a resolution is in the process of being implemented.
Posted Nov 16, 2020 - 11:41 UTC
This incident affected: Threat Intelligence Services (Anti-Spam).