Service Alert for Cyren Cloud Security (Web & DNS) Service
Incident Report for Cyren Cloud
Resolved
This incident has been resolved.
Posted 10 days ago. Sep 10, 2019 - 10:57 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 22 days ago. Aug 29, 2019 - 17:44 UTC
Investigating
We are currently investigating this issue.
Posted 22 days ago. Aug 29, 2019 - 14:52 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 22 days ago. Aug 29, 2019 - 12:39 UTC
Investigating
We are currently experiencing a performance issue affecting our French Data Center. This is impacting our Web Security and DNS Security services provided via this Data Center. The issue is under investigation.
Posted 22 days ago. Aug 29, 2019 - 12:23 UTC
This incident affected: Cyren Cloud Security (Web Security, DNS Security).