Service Alert for Cyren Cloud Security - Quarantine accessibility issue
Incident Report for Cyren Cloud
Resolved
This incident has been resolved.
Posted 3 months ago. May 21, 2019 - 18:24 UTC
Update
Upon Production roll-out of the Hot Fix attempting to address the Quarantine accessibility issue an undesired side-effect has been introduced which is preventing the display of the Email Tracking Logs.

Apologies for the inconvenience, we are aware and working hard to rectify these accessibility issues as fast as possible.
Posted 3 months ago. May 21, 2019 - 11:24 UTC
Identified
An issue has been identified which is affecting the access to individual quarantine accounts. Admins are currently unable to view and recover messages. Quarantine Digest emails are being delivered as scheduled.

A Hot Fix is in progress and will be released upon verification.

For any urgent emails requiring to be recovered, please contact Cyren Support via support@cyren.com.
Posted 3 months ago. May 20, 2019 - 14:39 UTC
This incident affected: Cyren Cloud Security (Admin Portal).