Detection degradation in Anti-Spam and URL Filtering service
Incident Report for Cyren Cloud
Resolved
This incident has been resolved.
Posted Jul 30, 2020 - 17:29 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 30, 2020 - 15:24 UTC
Investigating
We are currently experiencing an issue in our Anti-Spam and URL Filtering backend which leads to degraded detection. We are working to resolve the issue.
Posted Jul 30, 2020 - 14:19 UTC
This incident affected: Threat Intelligence Services (URL Filtering, Anti-Spam).