Service Alert for Cyren Web Security Service
Incident Report for Cyren Cloud
Resolved
This incident has been resolved.
Posted Mar 13, 2020 - 13:04 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 13, 2020 - 12:35 UTC
Identified
The issue has been identified. Please make sure to exclude the "UK (London)" data center in your Cyren Web Security settings to prevent browsing through the IP address of this data center.
Posted Mar 13, 2020 - 10:59 UTC
Investigating
We are currently experiencing an issue in regards to our UK data center. You might experience browsing issues.

We are investigating.
Posted Mar 13, 2020 - 10:24 UTC
This incident affected: Cyren Cloud Security (Web Security).