New transactions are not processed by Cyren Inbox Security
Incident Report for Cyren Cloud
Resolved
This incident has been resolved.
Posted Oct 01, 2020 - 08:48 UTC
Update
We are continuing to investigate the issue. Microsoft reported a problem with their Office 365 service that might be related to the issue we are investigating. We are currently checking how to reduce the impact on customers.
Posted Oct 01, 2020 - 07:44 UTC
Investigating
We are currently observing an issue with the Cyren Inbox Security service. Most transactions are currently not processed.
The issue started at 6:30 AM UTC.
Posted Oct 01, 2020 - 07:34 UTC
This incident affected: Cyren Inbox Security (Remediation).