Cyren Inbox Security Email Processing Delay
Incident Report for Cyren Cloud
Resolved
This incident has been resolved.
Posted Feb 15, 2022 - 12:44 UTC
Investigating
We have identified an ongoing issue that is causing delays with email processing and button scans by Cyren Inbox Security.

This is actively being worked upon by our Cyren Inbox Security operations team.
Posted Feb 15, 2022 - 12:29 UTC
This incident affected: Cyren Inbox Security (Outlook Add-In, Remediation, Email Processing).