Slow email processing by Cyren Email Security service
Incident Report for Cyren Cloud
Resolved
The issue has been resolved.
Posted Jul 03, 2020 - 20:37 UTC
Update
We have applied a workaround to address the slow email processing.
The issue is still under investigation.
Posted Jul 03, 2020 - 17:22 UTC
Investigating
We are investigating a slow down in email processing by Cyren Email Security service.
Posted Jul 03, 2020 - 16:44 UTC
This incident affected: Cyren Cloud Security (Email Security).