Service Alert for Cyren Email Security-Detection degradation
Incident Report for Cyren Cloud
Resolved
This incident has been resolved.
Posted Dec 30, 2020 - 16:00 UTC
Investigating
We are currently experiencing an issue in our backend which leads to degraded detection. We have identified that the degradation began at 09:30 AM UTC.
We are working to resolve the issue.
Posted Dec 30, 2020 - 11:12 UTC
This incident affected: Cyren Cloud Security (Email Security).