Service Alert for Cyren Email Security
Incident Report for Cyren Cloud
Resolved
This incident has been resolved.
Posted Apr 15, 2020 - 17:01 UTC
Identified
Due to a network outage in one of our Datacenters and the ongoing repair work some incoming connections to the Cyren Email Security Servers are currently failing.
This can lead to emails being delayed and some emails being received multiple times due to timeouts in the SMTP-communication between the sender and Cyren Email Security.
Posted Apr 15, 2020 - 10:40 UTC
This incident affected: myEleven (Email Security) and Cyren Cloud Security (Email Security, Admin Portal).