Issue with Cyren Data Center in Ashburn, US
Incident Report for Cyren Cloud
Resolved
This incident has been resolved.
Posted May 25, 2021 - 00:21 UTC
Monitoring
The issue has been resolved. We are monitoring the systems.
Posted May 24, 2021 - 19:27 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted May 24, 2021 - 04:00 UTC
Investigating
We are investigating an issue in our data center in Ashburn, US.
Posted May 24, 2021 - 00:58 UTC
This incident affected: Intelligence Feeds (Malware URL, Malware File) and Threat Intelligence Services (Anti-Malware, ThreatLookup API).