Cyren Inbox Security Email Processing Issue
Incident Report for Cyren Cloud
Resolved
This incident has been resolved.
Posted Mar 16, 2021 - 06:09 UTC
Monitoring
We are seeing a reduction in Cyren Inbox Security email processing alerts, and will continue monitoring the situation until it's full resolution.
Posted Mar 15, 2021 - 22:24 UTC
Identified
Due to an issue with a 3rd party service, Cyren Inbox Security users may experience delays and errors with email processing and on-demand scanning.
We are monitoring the situation closely and tracking updates on https://status.azure.com/en-us/status
Posted Mar 15, 2021 - 19:43 UTC
This incident affected: Cyren Inbox Security (Outlook Add-In, Remediation).