Service Alert for Cyren Cloud Security, Anti-Spam and URL Filtering
Incident Report for Cyren Cloud
Resolved
This incident has been resolved.
Posted Nov 27, 2019 - 09:33 UTC
Monitoring
The URL blob.core.windows.net was incorrectly classified as "spam" between November 25, 2019 at 22:18 UTC and November 26, 2019 at 09:16 UTC, which resulted in false positives in Cyren Cloud Security, Anti-Spam, and URL Filtering services.

We are investigating the root cause for this issue. Please contact Cyren support to request a root cause analysis document.
Posted Nov 26, 2019 - 19:16 UTC
This incident affected: Threat Intelligence Services (URL Filtering, Anti-Spam) and Cyren Cloud Security (Email Security).