Service alert for Cyren Web Security and Cyren DNS Security
Incident Report for Cyren Cloud
Resolved
This incident has been resolved.
Posted 12 days ago. Aug 05, 2019 - 12:57 UTC
Investigating
We are investigating an issue with Cyren data center in Milan, Italy, which became unavailable at 22:25 UTC on August 4, 2019. The data center was taken out of service at 23:00 UTC. Users may have experienced errors for a short period while failing over to another available Cyren data center.
Posted 13 days ago. Aug 04, 2019 - 23:15 UTC