Service Alert for Cyren Cloud Security - Updates to Cyren Cloud Security delayed
Incident Report for Cyren Cloud
Resolved
This incident has been resolved.
Posted Dec 16, 2020 - 17:41 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 16, 2020 - 17:26 UTC
Update
Changes to the email configuration and policies in the Cyren Cloud Security service are taking effect again.
We are now working to implement a fix for Cyren Web Security.
Posted Dec 16, 2020 - 14:57 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Dec 16, 2020 - 10:57 UTC
Investigating
We are currently experiencing a database replication issue with our Cyren Cloud Security product. Changes to the configuration and policies are currently not taking effect. Additionally, this is impacting reports which are currently not being updated.

The issue is under investigation.
Posted Dec 16, 2020 - 09:42 UTC
This incident affected: Cyren Cloud Security (Email Security, Admin Portal).