Service Alert for Cyren Email Security
Incident Report for Cyren Cloud
Resolved
The issue has been resolved, and as of 21:56 UTC we did not observe any transactions blocked by Spamhaus SBL.
Posted Feb 24, 2020 - 22:36 UTC
Monitoring
The IP address 195.190.135.20 has been removed from Spamhaus SBL. We are monitoring the service for the change to take effect.
Posted Feb 24, 2020 - 22:14 UTC
Investigating
We have identified an issue within the Cyren Email Security infrastructure which is causing failed delivery of inbound emails. One of our IPs ( 195.190.135.20 ) has become listed on the Spamhaus Block List. We are presently working with their support team to have this blocking removed.
Posted Feb 24, 2020 - 17:47 UTC
This incident affected: Cyren Cloud Security (Email Security).