Spain Data Center Outage
Incident Report for Cyren Cloud
Resolved
As of 09:00 UTC, access to the Spanish data center has been restored and it was put back in service at 10:00 UTC.
We are waiting for the root cause analysis from the data center service provider.
Posted 27 days ago. Jul 22, 2019 - 10:09 UTC
Investigating
Investigating - We are investigating an issue with Cyren data center in Madrid, Spain, which became unavailable at 06:20 UTC on July 22, 2019. Users may have experienced errors for a short period while failing over to another available Cyren data center.
Posted 27 days ago. Jul 22, 2019 - 07:22 UTC
This incident affected: Cyren Cloud Security (Web Security, DNS Security).