Service alert for Cyren Email Security affecting Digest reports
Incident Report for Cyren Cloud
Resolved
This incident has been resolved.
Posted Oct 28, 2019 - 08:36 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 27, 2019 - 12:11 UTC
Investigating
We are currently investigating an issue affecting the delivery of email digest reports between 01:00 - 10:00 (UTC).
Posted Oct 27, 2019 - 12:03 UTC
This incident affected: myEleven (Email Security) and Cyren Cloud Security (Email Security).