Service Alert for Cyren Email Security
Incident Report for Cyren Cloud
Resolved
This incident has been resolved.
Posted Oct 25, 2020 - 00:35 UTC
Update
We are continuing to investigate this issue.
Posted Oct 24, 2020 - 23:26 UTC
Investigating
Due to lost internet connection to one of our DCs, we are currently experiencing some email delays.
Posted Oct 24, 2020 - 22:30 UTC
This incident affected: Cyren Cloud Security (Email Security).