Service alert for Cyren Email Security
Incident Report for Cyren Cloud
Resolved
This incident has been resolved.
Posted Nov 08, 2019 - 00:01 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 07, 2019 - 22:56 UTC
Investigating
We have detected an issue which may affect delivery time of messages.
We are currently investigating this issue.
Posted Nov 07, 2019 - 22:10 UTC
This incident affected: myEleven (Email Security) and Cyren Cloud Security (Email Security).