Service Alert for Cyren Email Security Archiving
Incident Report for Cyren Cloud
Resolved
This incident has been resolved.
Posted May 11, 2021 - 16:03 UTC
Investigating
We are currently investigating an issue with the Archiving in Cyren Email Security. The service is not available since 13:06 UTC.

This only affects the archiving service, Cyren Email Security itself is not affected.
Posted May 11, 2021 - 14:49 UTC
This incident affected: Cyren Cloud Security (Email Security).