Cyren Inbox Security Processing Delay
Incident Report for Cyren Cloud
Resolved
This incident has been resolved.
Posted Aug 27, 2021 - 15:21 UTC
Monitoring
The issue has been mitigated and we are monitoring the current throughput levels to ensure normal levels of processing.
Posted Aug 27, 2021 - 14:18 UTC
Investigating
We have identified an issue that causes delays with email processing and button scans by Cyren Inbox Security which began at 10:35 UTC.

This is currently actively being investigated.
Posted Aug 27, 2021 - 11:43 UTC
This incident affected: Cyren Inbox Security (Outlook Add-In, Email Processing).