Delays in sending some messages through TLS in Cyren Email Security
Incident Report for Cyren Cloud
Resolved
This incident has been resolved.
Posted Jul 03, 2020 - 17:15 UTC
Monitoring
Starting on June 19th around 21:26 UTC we have been observing a number of temporary errors while establishing TLS connections to some servers. We identified this issue to be caused by an error in the implementation of TLS 1.3 in the mail server software which is used by a part of our outbound infrastructure for Cyren Email Security. You might have received some temporary error messages or delay notifications when trying to send email.

We implemented a workaround until a new version of our mail server software can be rolled out.
Posted Jun 22, 2020 - 12:33 UTC
This incident affected: myEleven (Email Security) and Cyren Cloud Security (Email Security).