Cyren Inbox Security Email Processing Issue
Incident Report for Cyren Cloud
Resolved
This incident has been resolved.
Posted Mar 18, 2021 - 19:23 UTC
Investigating
Due to an issue with a 3rd party service, Cyren Inbox Security users may experience delays and errors with email processing and on-demand scanning.
We are monitoring the situation closely.
Posted Mar 18, 2021 - 13:09 UTC
This incident affected: Cyren Inbox Security (Outlook Add-In, Remediation).