Network issue at Cyren US West data center
Incident Report for Cyren Cloud
Resolved
This incident has been resolved.
Posted 2 months ago. Jun 17, 2019 - 04:36 UTC
Identified
The issue has been identified as a power issue at the facility. We are working on restoring the service in the US West data center.
The issue did not affect front-end systems and customer Anti-Spam, URL Filtering and IP Reputation requests continued to function as expected.
Posted 2 months ago. Jun 17, 2019 - 01:52 UTC
Investigating
We are investigating a network issue that started at 20:40 UTC.
Posted 2 months ago. Jun 16, 2019 - 22:33 UTC
This incident affected: Threat Intelligence Services (URL Filtering, Anti-Spam, IP Reputation).