Service Alert for Cyren Email Security
Incident Report for Cyren Cloud
Resolved
This incident has been resolved.
Posted Oct 29, 2020 - 11:44 UTC
Monitoring
We are currently no longer observing any blocked messages due to the IP blacklisting. The last email was blocked at 10:17 UTC.
We will continue to monitor the traffic.
Posted Oct 29, 2020 - 10:39 UTC
Investigating
We are experiencing an issue with inbound email delivery which started at 05:14 UTC.

One of our inbound delivery hosts (IP 195.190.135.10) became listed on the Spamhaus blocklist and was delisted at 09:53 UTC.
This is affecting delivery to customers who use the Spamhaus blocklist which includes O365 customers.

We are currently investigating the root cause of the issue and working to mitigate the impact.

We recommend that customers do not make use of any additional IP based anti-spam measures on inbound delivery from our servers.
O365 customers should make sure that they have our inbound IP ranges whitelisted.

195.190.135.0/24 (195.190.135.0 - 195.190.135.255)
194.145.224.0/24 (194.145.224.0 - 194.145.224.255)
Posted Oct 29, 2020 - 10:19 UTC
This incident affected: myEleven (Email Security) and Cyren Cloud Security (Email Security).