Possible connectivity issues in Sunnyvale, US, datacenter
Incident Report for Cyren Cloud
Resolved
This incident has been resolved.
Posted Oct 22, 2020 - 16:20 UTC
Investigating
We are currently investigating an issue with our load balancers. Failover to other data centers will happen automatically. Nevertheless, you might see some errors.
The issue started at 14:05 UTC.
Posted Oct 22, 2020 - 14:05 UTC
This incident affected: Threat Intelligence Services (URL Filtering, Anti-Spam, IP Reputation).